enero 23, 2021, 11:22:39 am

Noticias:

Si tienes problemas para ingresar: puedes escribir a [email protected] para soporte técnico.


Problemas servidor ftp con modem CTC atu r130

Iniciado por enriquezil, noviembre 29, 2011, 04:39:25 am

Tema anterior - Siguiente tema

enriquezil

Hola gente, yo se que ya hay varios temas creados sobre este módem específicamente pero ya los he visto todos y todavía no lo logro hacer funcionar el servidor.

Bueno yo lo que quiero es poder ver mi servidor FTP de mi pc desde fuera de la red de mi casa, para evitarme algo de problemas la conecte directamente al módem la pc, en la configuración del módem en la parte de Services, entre en NAT , agregue una nueva regla, escogí RDR, coloque la ip del pc y la ip publica estática y puse el puerto 21, también probé con distintas combinaciones como en vez de RDR poner FILTER o abrir todos los puertos, pero por alguna razón no me esta sirviendo.

El servidor FTP si me funciona perfectamente desde la red local, actualmente tengo instalado Fedora 15 , pero también probé con Ubuntu y Mac y  tampoco tuve resultados.
Antes de colocar la regla en NAT y tratar de conectarme al servidor con mi ip publica me salia una especie de servidor ftp pero parece que es algo propio del módem porque solo con los datos del módem me podía conectar pero en cambio cuando ponía la regla en NAT para hacer la redireccion del puerto 21 a mi pc me decía algo de que tenia problemas para conectarse con el servidor, el mismo mensaje que sale cuando uno no puede entrar a alguna pagina web.

Las pruebas las hice desde otra conexión a Internet, les estaría muy agradecido si me podrían ayudar. Gracias
   
La peor prisión es un corazón cerrado. Papa Juan Pablo II

maucostarico

usted tiene algun swich o router conectado al modem? usa cablemodem?

enriquezil

Originalmente tengo conectado un router , pero para las pruebas conecto directamente la portátil al módem para evitarme problemas, tengo ADSL del ICE
La peor prisión es un corazón cerrado. Papa Juan Pablo II

JorgeAVM

Hola!
Y ya probó usando el modo pasivo del FTP?

Otra cosa es que podrías ocupar abrir más puertos.

enriquezil

Hola, eh no eso del modo pasivo no me suena que lo haya probado , donde se encuentra eso.
La peor prisión es un corazón cerrado. Papa Juan Pablo II

maucostarico

creo que se encuentra en donde se pone el puerto 21 si no más mal recuerdo.

enriquezil

Hola gente, acabo de probar instalando un servidor web en mi compu y si lo puedo ver,  entonces el problema solo involucra al FTP, no se si afectara en algo que las pruebas las haga con un iphone con internet aparte
La peor prisión es un corazón cerrado. Papa Juan Pablo II

maucostarico

iPhone  :auch:  jajajajaja... al rato hay alguna incompatibilidad. digo.

enriquezil

jajajaja y ya ni el iphone tengo porque ya se lo llevaron, si tan solo hubiera alguien que quisiera compartir el wifi por un momento jejeje
La peor prisión es un corazón cerrado. Papa Juan Pablo II

enriquezil

Si parece que las 3 computadoras tienen el ftp en modo pasivo , lo probare mas tarde en el modo activo a ver que sucede debido a que en este momento no puedo hacer las pruebas
La peor prisión es un corazón cerrado. Papa Juan Pablo II

JorgeAVM

Intente abrir más puertos, empezando desde el 20 hasta el 20000, solo para descartar que se trate de eso.

Veo que ya averiguaste lo del modo pasivo, es una opción que se selecciona del lado del cliente.

enriquezil

Hola gente, hay algunos avances, hice las pruebas en una pc , el servidor ftp que tiene instalado se llama PureFTPd, con ese si me sirvió, pero en la otra computadora donde quiero tener el servidor ftp no se sirvió, tiene otro que se llama PROFTPD, es el que uso en Fedora,  estuve leyendo y alguna gente le paso lo mismo y con solo poner esto (PassivePorts 49156 65534) en el archivo de configuración y abrir esos puertos en el módem y router lo arreglaron, ahora mas tarde hago las pruebas haber si me funciona.

Después tengo una dudilla cuando uno va abrir puertos, al final de la ventana hay 3 casillas que dicen :
                                                                                                                                                                                             Destination Port From:
                                                                                                                                                                                             Destination Port To:
                                                                                                                                                                                             Local Port:

Yo tengo creadas 3 reglas con estos datos y así es como me funciona en la otra pc:

 Destination Port From:21
 Destination Port To:21
 Local Port:21

 Destination Port From:20
 Destination Port To:20
 Local Port:20

 Destination Port From:80
 Destination Port To:80
 Local Port:  80                        


Pero en el caso que tenga que abrir varios puertos  como digamos para lo del modo pasivo  (PassivePorts 49156 65534) , que puerto tendría que poner en la ultima casilla que dice LOCAL PORT, o con solo poner 0 debería funcionar.

GRACIAS                                                                                                                                    
La peor prisión es un corazón cerrado. Papa Juan Pablo II

JorgeAVM

Creo que es así:

 Destination Port From:49156
 Destination Port To:65534
 Local Port:  0

enriquezil

Hola Jorge, Bueno ya definitivamente estoy seguro que en lo que respecta a la configuración del módem y router no hay problemas, el problema estaría en la configuración del proftpd, se podría decir que ya esta solucionado porque probé con gadmin-proftpd que es la implementacion de proftpd con interfaz, hice la configuración normal y me funciono, así  que lo único que tendría que hacer es revisar el archivo proftpd.conf que genera gadmin y ver que modificaciones tiene  con respecto al anterior y probarlo
La peor prisión es un corazón cerrado. Papa Juan Pablo II

JorgeAVM

Revise asuntos de Firewall también, si lo tiene.

Buscar en el Foro: