diciembre 05, 2020, 06:15:37 am

Noticias:

Para hacer tu consulta: debes registrarte y hacer un nuevo tema en la sección que consideres más adecuada. Ver: Acerca de este Foro.


Solucion a viejo problema con camaras D-link DCS-900w

Iniciado por edocha, mayo 17, 2011, 03:06:10 pm

Tema anterior - Siguiente tema

edocha

Tengo casi un año buscando poder ver desde cualquier parte mis dos camaras inalambricas d-link DCS-900w
Tengo ADSL del ICE com IP fija suministrado por un modem tenda d840r.  Al modem le he conectado un linksys wrt54g.
Mi ip es fija (201.205.xxx.xxx), cuando conecto el wrt54g en la primer boca del modem, el wrt54g toma la ip 192.168.1.2
A las camaras les he asigado las ips  192.168.5.110 y 192.168.5.112 asignadas por el wrt54g y tienen la opción de abrir un segundo puerto (NO se como se utiliza esa opción). He marcado en la primer camara el puerto 8080 y en la segunda 8090.
Tanto en el wrt54g como en el modem d840r he realizado el NAT para los puertos antes mencionados (8080 y 8090).
No logro ver la segunda camara.  Será porque la unica comunicación entre modem y wrt54g se da a traves de la ip 192.168.1.2 y las dos camaras generan conflicto..
Como solucionar dicho problema....

JorgeAVM

Está mal tu configuración, ya que en el modem ADSL tienes que redireccionar todos los puertos a la IP 192.168.1.2 del router WiFi. Luego en el router WiFi sí lo dejas como está, es decir, redireccionas los puertos 8080 y 8090 uno a capa IP correspondiente a las cámaras.

:okas:

edocha

Lo que me dices en que en el Modem, para la ip 192.168.1.2, debo haver NAT de la siguiente manera:
8080 192.168.1.2
8090 192.168.1.2
Y en el linksys debo hacer
8080 para 192.168.5.110 = Cam1
8090 para 192.168.5.112 = Cam 2
 
Favor corregirme si sigo herrado = caballo

JorgeAVM

Cita de: "edocha"... debo haver NAT de la siguiente manera:
8080 192.168.1.2
8090 192.168.1.2
Y en el linksys debo hacer
8080 para 192.168.5.110 = Cam1
8090 para 192.168.5.112 = Cam 2
 
Así es ... :okas:

edocha

Hoy en la noche hare los cambios.  Abriré en el modem tenda los dos puertos de las camaras (8080 y 8090) dirigidos a la ip 192.168.1.2 que es la asignada para el linksys wrt54g.  Dentro del linksys, pestaña Applications & Gaming le asignaré los puertos 8080 y 8090 a cada camara con su respectiva ip.
Mañana contaré como me fué.
 
Gracias

JorgeAVM


edocha

Anoche realice los cambios sugeridos y lamentablemente sigo sin poder ver mis camaras
Adjunto imagenes de las configuraciones.
Cualquier otra sugerencia se agradecera.
 

[archivo adjunto borrado por antigüedad]

edocha

Extrañamente desde mi oficina utilizo el siguiente programa: http://www.yougetsignal.com/tools/open-ports/
Al colocar la IP de mi casa y el puerto 8090 u 8100, el programa indica que dichos puertos estan abiertos pero no puedo ver ninguna de las camaras.
En algo fallo ya que estando dentro de mi red veo las dos perfectamente.

JorgeAVM

Bien, la configuración se ve bien pero tengo un par de dudas.

1-En la red 192.168.35.0/24 Qué IP tiene el Linksys? Creería yo que sería: 192.168.35.1 ... confirmar este dato por favor.

2-Las cámaras yo pensarían que usan el protocolo UDP, usted les puso únicamente el TCP, cambie la opción a BOTH para que funcione con TCP y UDP.

edocha

Al linksys le asigne la ip fija que proporciona el modem (192.168.1.2).  El linksys tiene la ip 192.168.35.5 como se ve en el gateway de la configuracion de la camara.
De la forma inalambrica comienza a partir de 100, es por eso que le asigne 110 y 112 a las camaras para dar un espacio entre la ip que puede tomar la portatil de la doña y la mia.
Cuando utilizo una sola camara, estando activado TCP la veo perfectamente desde mi oficina.  El problema surge cuando agrego la otra, logicamente con diferentes puertos a los de la cam1

JorgeAVM

A las cámaras deberías ponerle IPs que estén fuera del rango de DHCP precisamente para que no haya otro equipo que tome las IPs de las cámaras. Póngales algo como 192.168.35.10 y 192.168.35.10

Lo que te preguntaba del linksys era por lo mismo, ya que usas la IP192.168.35.5 como gateway y me pareció extraña esa IP, pero si esa es la que tiene, entonces está bien. Por lo demás cambie el NATeo a (BOTH) ambos protocolos y vemos si eso es lo que falta.

edocha

Le asigne a la cam1=192.168.35.10 y cam2=192.168.35.12.  Un rango fuera del DHCP como indicaste.
Cambie en el MODEM de TCP a AMBOS
Cambie en el linksys las nuevas ip (10 y 12) y cambie TCP por AMBOS.
NO FUNCIONA.
Las camaras tienen la opcion de abrir un segundo puerto, pero no se que hacer con él.
Tampoco se que DNS ponerle a las camaras si 192.168.1.1 que corresponde al modem o las DNS que vienen internamente en la conficuración del TENDA
He pensado en instalar otro WRT54G para crear otra red y configurar la otra camara de acuerdo a esa red.
No sería una solucion correcta ya que se supone que puedo agregar varias camaras a la misma red.

JorgeAVM

Sí está raro el asunto. Revise opciones de Firewall en ambos routers, opciones menos restrictivas, principalmente en el ADSL. (Si las hubiera)

Bueno, por aquello, recuerde que para acceder a las cámaras desde otra ubicación mediante Internet, debes introducir la IP pública y el número de puerto correspondiente, por ejemplo:

200.91.130.220:8090

Otra cosa que acabo de ver, es que las cámaras trasnmiten las imágenes por otro puerto, el cual no puede repetirse entre ellas, en tu captura está el puerto 8481, el cual no puede ser el mismo en ambas cámaras y que es probable que también tengas que abrir en los routers.

edocha

Perdon hubo un error
Open Second Port
The Open Second Port option is used when multiple cameras are being installed on a network OR for using a port other than the default port for image viewing. For each additional camera that is installed, you must select the Open Second Port Option and assign the appropriate Web server and Transfer Image ports for each camera to enable remote viewing.
By default, ports 80 (Web server port) and 8481 (for camera image viewing) are open. If these ports are available for use, you DO NOT have to open a second port and can proceed to the next section. If port 80 is not available (for example, if you are already using port 80 to run a webserver or your ISP blocks access on port 80*) you MUST open a second port and designate a new Web server port (81, 82, 83,...etc) AND a new image transfer port (8482, 8483,...etc). IMPORTANT: Be sure to take note of these settings since these same settings will be used to configure your router.

JorgeAVM

Eso confirma lo que te decía ... el puerto 8481 seguramente está repetido en ambas y no puede ser así, use puertos diferentes por cada cámara.
"designate a new Web server port (81, 82, 83,...etc) AND a new image transfer port (8482, 8483,...etc)."

Buscar en el Foro: