Octubre 28, 2020, 06:15:26 am

Noticias:

Para hacer tu consulta: debes registrarte y hacer un nuevo tema en la sección que consideres más adecuada. Ver: Acerca de este Foro.


instalar debian en disco serial ATA

Iniciado por juankasalas, Enero 27, 2007, 04:22:49 am

Tema anterior - Siguiente tema

juankasalas

hola, como acabo de comprar un disco serial ata, trate de instalar Debian etch en el, pero cuando llega a la parte de la detección del disco duro no pudo hallarlo.

la verdad es que me meti en las opciones arranque como experto y en una parte me pidio el driver, le meti el disco que venia con la tarjeta y ni aún así lo pude hacer. alguna ayuda que me puedan dar es bien recibida, ya que creo es un problema que se le ha presentado a varios.
Nunca te rindas... DIOS nunca lo hizo y por amor murió por tí en la Cruz
Linux User #432799 Machine ID:  #337816

Mi sistema
AMD Phenom X4 3.2 ghz Asus M4A78T-E
2 GB CORSAIR MSI ATI HD 5600
DELL 1905FP WD 1 TB 16 MB

/*charlie*/

Cita de: "juankasalas"hola, como acabo de comprar un disco serial ata, trate de instalar Debian etch en el, pero cuando llega a la parte de la detección del disco duro no pudo hallarlo.

la verdad es que me meti en las opciones arranque como experto y en una parte me pidio el driver, le meti el disco que venia con la tarjeta y ni aún así lo pude hacer. alguna ayuda que me puedan dar es bien recibida, ya que creo es un problema que se le ha presentado a varios.

Trata con otra distro, a mí Fedora Core 6 me solucionó el problema.
Un saludo. 8)

juankasalas

de hecho

bueno de hecho estoy escribiendo ahorita desde ubuntu 6.10 que me esta trabajando de mil maravillas.  pero no se me gusta más el tata que el hijo.

Pero aún así ubuntu esta muy bien.
Nunca te rindas... DIOS nunca lo hizo y por amor murió por tí en la Cruz
Linux User #432799 Machine ID:  #337816

Mi sistema
AMD Phenom X4 3.2 ghz Asus M4A78T-E
2 GB CORSAIR MSI ATI HD 5600
DELL 1905FP WD 1 TB 16 MB

chaco

Cita de: "juankasalas"hola, como acabo de comprar un disco serial ata, trate de instalar Debian etch en el, pero cuando llega a la parte de la detección del disco duro no pudo hallarlo.

la verdad es que me meti en las opciones arranque como experto y en una parte me pidio el driver, le meti el disco que venia con la tarjeta y ni aún así lo pude hacer. alguna ayuda que me puedan dar es bien recibida, ya que creo es un problema que se le ha presentado a varios.

Primero varias recomendaciones

1- entrar en la bios de tu maquina y decirle al sistema que trate el disco serial ata como un disco ide sera una opcion parecida a esta ide emulation enabled

Suelen decir por ahi que inicialmente cuando vas a instalar el sistema que modifiques la bios para decirle que funcione en modo emulacion ide para poder instalar el sistema debian sin problemas, para posteriormente instalar el parche correspondiente, poner de nuevo la opcion de la bios ide emulation a disabled y arrancar al fin con soporte serial ata

2- Busque en el bios los dispositivos sata, por default no esta en modo combination cambielo

3- Usar debian :) que es 100% gnu.
This is Unix-Land. In quiet nights, you can hear the Windows machines reboot"

juankasalas

voy a intentarlo

lo voy a intentar y ahi les cuento como me va...

y si, me gusta mucho más debian pero he bajado la imagen de debian 64 bits 2 veces y en ambos casos no me bootea...
Nunca te rindas... DIOS nunca lo hizo y por amor murió por tí en la Cruz
Linux User #432799 Machine ID:  #337816

Mi sistema
AMD Phenom X4 3.2 ghz Asus M4A78T-E
2 GB CORSAIR MSI ATI HD 5600
DELL 1905FP WD 1 TB 16 MB

chaco

Re: voy a intentarlo

Cita de: "juankasalas"lo voy a intentar y ahi les cuento como me va...

y si, me gusta mucho más debian pero he bajado la imagen de debian 64 bits 2 veces y en ambos casos no me bootea...

Podes dar mas detalle de tu controlador sata

Tenes un procesador de 64 bits ?

Bueno podes instalar con el de 32 y luego cambias los source list del apt y "dist-upgradeas" tu debian  :P
This is Unix-Land. In quiet nights, you can hear the Windows machines reboot"

juankasalas

sip

sip un amd 64 bits socket AM2

controlador Serial ATA VT8237A en una tarjeta madre MSI K9VGM-V
Nunca te rindas... DIOS nunca lo hizo y por amor murió por tí en la Cruz
Linux User #432799 Machine ID:  #337816

Mi sistema
AMD Phenom X4 3.2 ghz Asus M4A78T-E
2 GB CORSAIR MSI ATI HD 5600
DELL 1905FP WD 1 TB 16 MB

chaco

Re: sip

Cita de: "juankasalas"sip un amd 64 bits socket AM2

controlador Serial ATA VT8237A en una tarjeta madre MSI K9VGM-V

Mira esto


http://permalink.gmane.org/gmane.linux.debian.user.spanish/107904
This is Unix-Land. In quiet nights, you can hear the Windows machines reboot"

juankasalas

sip

ya lo había leido, por eso baje etch en vez de sarge. E incluso le puedo agregar que Ubuntu con el kernel 2.6.17 me reconocio el controlador serial ATA.

tambien cambie lo del Raid a IDE, ya que si no tampoco podía instalar XP pv.

ya no se que cambiarle.
Nunca te rindas... DIOS nunca lo hizo y por amor murió por tí en la Cruz
Linux User #432799 Machine ID:  #337816

Mi sistema
AMD Phenom X4 3.2 ghz Asus M4A78T-E
2 GB CORSAIR MSI ATI HD 5600
DELL 1905FP WD 1 TB 16 MB

chaco

Re: sip

Cita de: "juankasalas"ya lo había leido, por eso baje etch en vez de sarge. E incluso le puedo agregar que Ubuntu con el kernel 2.6.17 me reconocio el controlador serial ATA.

tambien cambie lo del Raid a IDE, ya que si no tampoco podía instalar XP pv.

ya no se que cambiarle.


Esta solucion esta mas violenta

http://www.mail-archive.com/[email protected]/msg145668.html
This is Unix-Land. In quiet nights, you can hear the Windows machines reboot"

juankasalas

tampoco

he... existe un problema con esa solución, la cual es que a la persona que presenta el post, ya le reconocio el disco duro, el problema lo tiene con el formato de la partición. A mi no me reconoce el disco duro.
Nunca te rindas... DIOS nunca lo hizo y por amor murió por tí en la Cruz
Linux User #432799 Machine ID:  #337816

Mi sistema
AMD Phenom X4 3.2 ghz Asus M4A78T-E
2 GB CORSAIR MSI ATI HD 5600
DELL 1905FP WD 1 TB 16 MB

chaco

Re: tampoco

Cita de: "juankasalas"he... existe un problema con esa solución, la cual es que a la persona que presenta el post, ya le reconocio el disco duro, el problema lo tiene con el formato de la partición. A mi no me reconoce el disco duro.
:shock:
This is Unix-Land. In quiet nights, you can hear the Windows machines reboot"

gin

Posiblemente mi ayuda sea demasiado escueta pero porque no intentas instalar con el kernel 2.6, si es que no los haz hecho.

boot: linux26
blog.mbrenes.com

No hay vida en este cuerpo Yo soy nada, sin vida, sin alma ... odiado y temido, estoy muerto para todo el mundo. Escuchame... yo soy el monstruo al que los ho

chaco

Cita de: "shakka"Posiblemente mi ayuda sea demasiado escueta pero porque no intentas instalar con el kernel 2.6, si es que no los haz hecho.

boot: linux26

El cd de etch arranca ya con kernel 2.6
This is Unix-Land. In quiet nights, you can hear the Windows machines reboot"

Guest

Juanka
ya revisaste el BIOS muy bien porque es raro que no este  el modo combinacion para serial ata

o revisar bien que el kernel sea el 2.6 que no deberia tener problemas con el serial ata

aqui hay una guia de como hacerlo

recuerda que linux detecta los serial ata como SCSI
Discos rígidos scsi:
sda1............partición 1 del primer disco scsi
sda4............partición 4 del primer disco scsi
sdb1............particion 1 del segundo disco scsi


- Iniciar la instalación en modo experto; indicando el parámetro 'expert' al inicio.
- Antes de pasar a particionar el disco, se nos preguntará si queremos cargar algún módulo para controladoras scsi etc... es el momento de elegir el módulo de nuestra controladora de disco: en mi caso 'sata_uli'.
- Tras finalizar la instalación de los paquetes básicos, y elegir un gestor de arranque (Grub o Lilo) se nos pedirá reiniciar.

Con otras controladoras SATA se que con esto sería suficiente. Con la mía, en cambio, al reiniciar el ordenador en el arranque del sistema acaba por dar un error:

pivot_root: no such file /sbin/init: 432: cannot open dev/console: No such file

(apuesto a que esta línea atraerá unas cuantas visitas ;-)

Según he podido leer la causa de este error es que en el arranque el sistema no ha sido capaz de montar el dispositivo raiz. Esto es debido a que la imagen initrd creada para el arranque no contiene el módulo de carga de la controladora de disco en cuestión. Parece ser que es un fallo de la instalación de Debian con esta controladora.

Para solucionarlo:

- Arrancar el ordenador con un LiveCD con una buena autodetección hardware (Knoppix!).
- Montar la partición raíz: "mount /dev/sda1 /mnt"
- Hacer un: "chroot /mnt"

Y estaremos dentro de nuestro recien instalado sistema. Arreglemos el problema del arranque:

- Antes de nada abrir el fichero: '/etc/fstab' y aseguraros de que este bien creado.
- Ejecutar un: "mount /proc".
- Ahora deberiais tener red, y tal vez es un buen momento para descargaros la última versión del kernel disponible:



   1. Para configurar el gestor de paquetes:


apt-setup



   1. Para buscar la última versión del kernel disponible:


apt-cache search kernel-image-2.6*-686



   1. ...y para instalarlo:


apt-get install kernel-image-2.6.11-1-686



Tras realizar la instalación del kernel, el sistema autoconfigurará el gestor de arranque para incluirlo en el menú. Ahora solo falta asegurarse de que el initrd del arranque contiene los módulos necesarios:

- Edita el fichero '/etc/mkinitrd/modules' y añade los módulos necesarios para poder arrancar el sistema. En mi caso:



sata_uli

libata

scsi_mod

reiserfs



- Ahora podemos crear la nueva imagen:



   1. Renombramos la imagen actual:


mv /boot/initrd.img-2.6.11-1-686 /boot/initrd.img-2.6.11-1-686.bak



   1. Y creamos la nueva con el mismo nombre.:


mkinitrd -o /boot/initrd.img-2.6.11-1-686 2.6.11-1-686



Se supone que ya está! Solo hace falta que salgas del chroot y desmontes la partición antes de reiniciar el equipo:



umount -a

exit

umount /mnt

Buscar en el Foro: